Go Back   Dallas Fort Worth 5.0 Mustang Club > 5.0 Mustang Forum > Suspension

Suspension Post up questions about your Mustang's suspension or ride quality

Sponsored Ads
Welcome to DFW50s.com

Register to remove these ads.

Thread Tools Display Modes
Old 08-01-2015, 03:46 PM   #1
Junior Member
Join Date: Feb 2015
Age: 31
Posts: 17
Default Busted something in my suspension

Sorry, I know that title is REALLY vague, but I discovered that yesterday after getting all the stuff I need to replace my wiper cowl, which should arrive Thursday.

There was a dude in front of me at O' Reilly's in Azle that runs a hot rod shop and I asked if he minded checking my motor mounts because of an unrelated issue(most likely bad U-joints) and while I was purchasing what I needed, he did a walk around inspection and pointed out my left rear tire was tucked into the wheel well, a sign of something busted.

He told me to have someone put it on the rack for 5 minutes to figure out if it's a strut or one of the control arms.

Surprisingly it wasn't the potholes that caused it, it was more than likely the city dredging the ditch next to my driveway, and when I backed out, I rolled off it a few times.

Taimigrrl87 is offline   Reply With Quote
Old 08-02-2015, 10:44 PM   #2
Senior Member
Join Date: Oct 2014
Age: 43
Posts: 100

Is your car lowered? If so to keep the rear end aligned properly you need a pan hard bar. Mine did the same thing.

2012 Race Red Mustang 5.0 with JLT CAI, Catless midpipe, Pype X Pipe and Axle Backs. Bama Tuned. RTR chin splitter, Roush side effects and rear diffuser, and Steeda spoiler.
19" AMR's with Nero's.
Monolith is offline   Reply With Quote
Old 12-11-2017, 01:18 AM   #3
Junior Member
Join Date: Dec 2017
Posts: 7

were you able to fix the problem?
Must33 is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump