Go Back   Dallas Fort Worth 5.0 Mustang Club > Photos & Videos > Foxbody 5.0s

Foxbody 5.0s For the original 5.0s that started it all


Sponsored Ads
Welcome to DFW50s.com

Register to remove these ads.




Reply
 
Thread Tools Display Modes
Old 02-19-2014, 05:30 PM   #31
blownaltered
I have a small penis
 
Join Date: Nov 2012
Location: Making Steve my bitch since 2003
Age: 37
Posts: 1,465
Default

Originally Posted by 1andonlywhitie View Post
Since it's not blownaltered's it appears you have an unclaimed BD-11A... If it is in decent shape maybe we can come to an agreement on it lol. Let me know, it would be pretty awesome to get this sucker back together tonight...
It's a damn shame I'm an honest person. I so could have sold that damn thing and made me a quick buck, but it would haunt me for months for doing it.

I hope you get her up and running again soon. It oissed me off when I at my p1sc on my old GT.
blownaltered is offline   Reply With Quote
Old 02-19-2014, 05:33 PM   #32
1andonlywhitie
Senior Member
 
1andonlywhitie's Avatar
 
Join Date: Dec 2012
Location: McKinney
Posts: 144
Default

Originally Posted by blownaltered View Post
It's a damn shame I'm an honest person. I so could have sold that damn thing and made me a quick buck, but it would haunt me for months for doing it.

I hope you get her up and running again soon. It oissed me off when I at my p1sc on my old GT.
I appreciate the honesty lol. Now if Tim will work out what the deal is on it maybe I can snag it off them and get this turd running again... I've had the car for like 2 weeks and it seems I've barely even used it...
__________________
Current Ride: '91 LX Hatch 5.0 - 434WHP, Trashed Synchros, Slipping Clutch and Rattles For Days
Other Ride: 1987 Dodge D150
Previous Rides: '80 Escort MkII, '08 Bullitt, '50 F1, '48 Chevy, '67 El Camino, '50 Chevy, '13 Dodge Dart Turbo
1andonlywhitie is offline   Reply With Quote
Old 02-19-2014, 06:51 PM   #33
TrueStreetTim
DFW5.0s Preferred Vendor
 
TrueStreetTim's Avatar
 
Join Date: Aug 2012
Location: McKinney
Posts: 676
Default

Some reason I thought it was yours, Donny. Maybe because all your %#*& is ancient

I'm working on it as we speak.

Last edited by TrueStreetTim; 02-19-2014 at 07:10 PM.
TrueStreetTim is offline   Reply With Quote
Old 02-19-2014, 07:13 PM   #34
blownaltered
I have a small penis
 
Join Date: Nov 2012
Location: Making Steve my bitch since 2003
Age: 37
Posts: 1,465
Default

Originally Posted by TrueStreetTim View Post
Some reason I thought it was yours, Donny. Maybe because all your %#*& is ancient

I'm working on it as we speak.
My car parts are like me, old and broke in.
blownaltered is offline   Reply With Quote
Old 02-19-2014, 07:15 PM   #35
1andonlywhitie
Senior Member
 
1andonlywhitie's Avatar
 
Join Date: Dec 2012
Location: McKinney
Posts: 144
Default

Originally Posted by blownaltered View Post
My car parts are like me, old and broke in.
'Experienced'



I'm gonna use that next time I sell a car... ran when parked, motor has lots of prior experience....
__________________
Current Ride: '91 LX Hatch 5.0 - 434WHP, Trashed Synchros, Slipping Clutch and Rattles For Days
Other Ride: 1987 Dodge D150
Previous Rides: '80 Escort MkII, '08 Bullitt, '50 F1, '48 Chevy, '67 El Camino, '50 Chevy, '13 Dodge Dart Turbo
1andonlywhitie is offline   Reply With Quote
Old 02-19-2014, 10:27 PM   #36
1andonlywhitie
Senior Member
 
1andonlywhitie's Avatar
 
Join Date: Dec 2012
Location: McKinney
Posts: 144
Default

So I took the blower unit off and opened it up on the drive belt side expecting to see carnage... what I actually see is.....nothing really. Pulleys and drive belt look great, bearings on the top side look good. Only thing I do see, tiny little fragments of what look like a bearing, the weird thing is both pulleys are right where they need to be but they don't spin which is real odd as that side of the blower is isolated from the side that actually moves the air... more updates to come...


EDIT 1: Took off the back side of the blower, impeller looks good. Has a little wear on the fins but nothing to be too worried about. After a little looking with the flashlight it looks like the bearing that sits between the impeller and the drive pulley (on the same shaft) has seized. Need to somehow break loose the components on that shaft to get down to the problem, of course it's something BURIED in there, couldn't be an easy fix... on the plus side getting back into being able to work on this kinda stuff has been nice, kinda missed it...

EDIT 2: With no puller/press for bearings I subbed out the bearing replacement to TrueStreet. Hopefully they can hook me up on it and I'll put it all back together... I want my damn car...
__________________
Current Ride: '91 LX Hatch 5.0 - 434WHP, Trashed Synchros, Slipping Clutch and Rattles For Days
Other Ride: 1987 Dodge D150
Previous Rides: '80 Escort MkII, '08 Bullitt, '50 F1, '48 Chevy, '67 El Camino, '50 Chevy, '13 Dodge Dart Turbo

Last edited by 1andonlywhitie; 02-21-2014 at 01:48 PM.
1andonlywhitie is offline   Reply With Quote
Old 02-21-2014, 07:32 PM   #37
1andonlywhitie
Senior Member
 
1andonlywhitie's Avatar
 
Join Date: Dec 2012
Location: McKinney
Posts: 144
Default

Car's fucked. Blower rebuild is more money than I have, car's in pieces in the garage. Straight up S.O.L. Traded in my fucking '13 Dodge and used equity to buy this in the plan on not having a payment...yeah that plan didn't work. /Rant.
__________________
Current Ride: '91 LX Hatch 5.0 - 434WHP, Trashed Synchros, Slipping Clutch and Rattles For Days
Other Ride: 1987 Dodge D150
Previous Rides: '80 Escort MkII, '08 Bullitt, '50 F1, '48 Chevy, '67 El Camino, '50 Chevy, '13 Dodge Dart Turbo
1andonlywhitie is offline   Reply With Quote
Old 03-01-2014, 10:36 AM   #38
1andonlywhitie
Senior Member
 
1andonlywhitie's Avatar
 
Join Date: Dec 2012
Location: McKinney
Posts: 144
Default

Got the blower back together and back on the car... runs good, took a mile or two to get its adaptations back after sitting with the battery unhooked for days on end.

Hopefully that's it for teething issues getting this thing daily ready..
__________________
Current Ride: '91 LX Hatch 5.0 - 434WHP, Trashed Synchros, Slipping Clutch and Rattles For Days
Other Ride: 1987 Dodge D150
Previous Rides: '80 Escort MkII, '08 Bullitt, '50 F1, '48 Chevy, '67 El Camino, '50 Chevy, '13 Dodge Dart Turbo
1andonlywhitie is offline   Reply With Quote
Old 01-31-2016, 01:41 AM   #39
Doug
Member
 
Join Date: Jul 2012
Location: Carrollton
Age: 50
Posts: 72
Default

Hows it running now?
__________________
Doug

1990 5.0 Coupe
1993 Vert
Doug is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump